当前位置:首页 >>其他 > WordPress升级php7.2不能自定义调用头部文件(实战解决)

WordPress升级php7.2不能自定义调用头部文件(实战解决)

百度: 已收录 | 发布日期:2019年04月01日 | 浏览:114 次

相信大家在使用wordpress的时候肯定很多小伙伴都在说php升级到7.0以上性能提升的不是一点是几倍,那么看到以后我们肯定都想升级解决速度问题。

那么我们在升级的时候遇到一些问题升级过后首页顶端提示错误代码

Warning: Use of undefined constant single – assumed ‘single’ (this will throw an Error in a future version of PHP) in /www/wwwroot/chinahzx.cn/wp-content/themes/lsw/single.php on line 1

我们应该怎么解决首先我们找到single.php的第一行 代码是这个 <?php get_header(single);?> 这里php7.0以后不支持自定义single,那么我们可以直接删除就能解决问题,但是我们想每个页面自定义头部文件那么我们应该怎么解决,很简单

看实现的步骤:

1、我们使用另外的一个php调用代码,把这个代码<?php get_header(single);?>换成 <?php include(“header-single”); ?>这个代码即可。 这个模板header-single你自己可以随便修改,当然是你后台有什么自定义的头部模板你就调用什么模板就行啦。

然后保存刷卡直接完美解决。

小白说支付
作者:卡卡哥(信用卡迷) 文章原创,转摘请注明出处!! 本文链接:http://www.chinahzx.cn/4356.html


发表评论

电子邮件地址不会被公开。 必填项已用*标注