当前位置:首页 >>pos机解密知识 > Baidu Sitemap Generator插件更新php7.0以上版本后不能正常使用

Baidu Sitemap Generator插件更新php7.0以上版本后不能正常使用

百度: 已收录 | 发布日期:2019年04月08日 | 浏览:353 次

广告

pos机流量卡

广告

pos机流量卡

Baidu Sitemap Generator插件更新php7.0以上版本后不能正常使用,wordpress之前就确认不在支持php5.6以下的版本,那么我们升级到php7.0以上版本肯定是必然的,我们在升级以后会有一些兼容性的问题。

Baidu Sitemap Generator插件更新php7.0以上版本后不能正常使用

下面卡卡哥就跟大家一起来解读一下Baidu Sitemap Generator插件更新后有哪些不兼容

导致sitemap_baidu、sitemap这俩个功能直接失效,不管是自动更新还是手动更新都不能正常的使用,那么我们应该怎么办?下面看操作。

第一步、我们需要修改插件目录下的sitemap-function.php文件的439行和 baidu_sitemap.php文件的308行改成如下

list( $today_year, $today_month, $today_day, $hour, $minute, $second ) = preg_split( ‘([^0-9])’, $blogtime );

把split修改成preg_split上面的代码已经修改修改后保存上传覆盖

第二步、在修改baidu_sitemap.php修改22行,下面看操作

/** add a Menu,like “Baidu Sitemap” **/
function baidu_sitemap_menu() {
/** Add a page to the options section of the website **/
if (current_user_can(‘manage_options’))
add_options_page(“Baidu-Sitemap”,”Baidu-Sitemap”, ‘8’, __FILE__, ‘baidu_sitemap_optionpage’);
}

把上面的8改成manage_options即可,然后保存上传覆盖,我们修改后上传后需要清除下浏览器记录值这里,然后在后台在生成就OK拉?当然这个不能自动更新,只有手动更新才有效

Baidu Sitemap Generator插件更新php7.0以上版本后不能正常使用

当然还有一个解决办法是什么?那就是我们如果使用的是宝塔面板那就更好办了,可以php版本切换,完美的解决这个问题!

Baidu Sitemap Generator插件更新php7.0以上版本后不能正常使用

小白说支付
作者:卡卡哥(信用卡迷)原创 转摘请注明出处!! 本文链接:https://www.chinahzx.cn/4417.html


评论已关闭。